Wie kann npm UNMET PEER ABHÄNGIGKEIT lösen?

Ich bin auf Windows 10, Knoten Version 5.6.0 und npm Version 3.6.0. Versucht, angular-material und mdi in meinen Arbeitsordner zu installieren. npm install angular-material mdi gibt mir folgende Fehlermeldungen:

+ – angular@1.5.0

+ – UNMET PEER ABHÄNGIGKEIT angular-animate@^1.5.0

+ – UNMET PEER ABHÄNGIGKEIT angular-aria@^1.5.0

+ – angular- Material@1.0.6

+ – UNMET PEER ABHÄNGIGKEIT angular-messages@^1.5.0 `- mdi@1.4.57

npm WARN enoent ENOENT: Keine solche Datei oder kein Verzeichnis, öffne ‘C: \ Users \ xxxxx \ Desktop \ ngClassifieds \ package.json’

npm WARN angle-material@1.0.6 benötigt einen Peer von angular-animate@^1.5.0, aber keiner wurde installiert.

npm WARN angle-material@1.0.6 benötigt einen Peer von angular-aria@^1.5.0, aber keiner wurde installiert.

npm WARN angle-material@1.0.6 benötigt einen Peer von angular-messages@^1.5.0, aber keiner wurde installiert.

Wie kann ich dies beheben, um eckiges Material und mdi zu installieren?

   

    npm installiert keine Peer-Abhängigkeiten mehr, so dass Sie sie manuell installieren müssen. Führen Sie einfach eine npm install auf den benötigten Deps aus und versuchen Sie dann, die Hauptversion erneut zu installieren.


    Auf Kommentar antworten:

    Es ist richtig in dieser Nachricht, es sagt, welche Depots du vermisst

     UNMET PEER DEPENDENCY angular-animate@^1.5.0 +-- UNMET PEER DEPENDENCY angular-aria@^1.5.0 +-- angular-material@1.0.6 + UNMET PEER DEPENDENCY angular-messages@^1.5.0 `-- mdi@1.4.57` 

    Also musst du npm install angular angular-animate angular-aria angular-material angular-messages mdi

    UNMET PEER DEPENDENCY Fehler wird ausgetriggers, wenn die Abhängigkeiten eines oder mehrerer Module in der Datei package.json nicht erfüllt sind. Überprüfen Sie die Warnungen sorgfältig und aktualisieren Sie die Datei package.json mit den korrekten Versionen der Abhängigkeiten.

    Dann renne

     rm -rf node_modules/ npm cache clean npm install 

    Dadurch werden alle erforderlichen Abhängigkeiten korrekt installiert.

    In meinem Fall waren alle Abhängigkeiten schon da. Bitte aktualisieren Sie NPM in diesem Fall, da es möglicherweise abgestürzt ist. Es hat mein Problem getriggers. npm install -g npm

    npm-install-peers hat für mich gearbeitet.

     npm install -g npm-install-peers 

    Eine der möglichen Ursachen für diesen Fehler könnte sein, dass Sie in Ihrem package.json eine ältere Version definiert haben. Um dieses Problem zu lösen, ändern Sie die Versionen in der Datei package.json so, dass sie mit denen übereinstimmen, über die sich npm beschweren.

    Sobald Sie fertig sind, führen Sie npm install und voila !!.

    Ok, also habe ich lange gekämpft, um das herauszufinden. Hier ist die nukleare Option, wenn Sie alle anderen Möglichkeiten ausgeschöpft haben ..

    • Erstellen Sie einen neuen Ordner auf Ihrem PC.
    • Lade eine brandneue eckige Installation herunter – ich habe diese Anleitung benutzt: https://coursetro.com/posts/code/55/How-in-Install-an-Angular-4-App
    • Führen Sie es aus, stellen Sie sicher, dass es funktioniert
    • Dann installieren Sie Ihre Abhängigkeiten nacheinander aus Ihrer package.json Datei
    • Führen Sie es nach jeder Installation aus

    Wenn Sie fertig sind und es immer noch funktioniert, importieren Sie Ihren tatsächlichen Code in dieses neue Projekt. Korrigieren Sie eventuelle Kompilierungserrors der neueren Version von eckigen Ursachen.

    Das war, was es für mich getan hat. 1 Stunde Rework vs 6 Stunden zu versuchen herauszufinden, wtf war falsch .. wünschte, ich habe es so gemacht zu starten ..

    Heute verfügbar Angular 2 rc.7 , und ich hatte ein ähnliches Problem mit rxjs@5.0.0-beta.12 UNMET PEER ABHÄNGIGKEIT.

    Wenn du, wie ich, einfach @angular/...rc.6 zu @angular/...rc.7 – es ist nicht genug. Zum Beispiel hat @angular/router keine rc.6 Version.

    In diesem Fall solltest du package.json im Schnellstart überprüfen

    Die gegebene Antwort funktioniert nicht immer. Wenn das Problem nicht behoben wird. package.json Sie sicher, dass Sie auch das richtige Symbol in Ihrem package.json . Dies ist sehr wichtig, um diese Kopfschmerzen zu beheben. Beispielsweise:

     warning " > @angular/compiler-cli@5.2.7" has incorrect peer dependency "typescript@>=2.4.2 <2.7". warning " > tsickle@0.25.6" has incorrect peer dependency "typescript@>=2.4.2 <2.6". 

    Also muss mein Typoskript zwischen 2.4.2 und 2.6 liegen, oder?

    Also änderte ich meine Typoskript-Bibliothek von "typescript": "^2.7" zu "typescript": "^2.5" . Scheint korrekt?

    Falsch.

    Das ^ bedeutet, dass du mit npm okay bist, wenn du "typescript": "2.5" oder "2.6" oder "2.7" etc ...

    Wenn du wissen willst was das ^ und ~ bedeutet, siehe: Was ist der Unterschied zwischen Tilde (~) und Caret (^) in package.json?

    Außerdem müssen Sie sicherstellen, dass das Paket existiert. Vielleicht gibt es kein "typescript": "2.5.9" suchen die "typescript": "2.5.9" nach. Um wirklich sicher zu sein, entfernen Sie einfach die ~ oder die ^ wenn Sie nicht lesen wollen, was sie bedeuten.

    Sie können dies beheben, indem Sie die UNMET-Abhängigkeiten global installieren.

    Beispiel: npm install -g @ angular / common @ 4.4.6

    Installieren Sie jedes einzeln. es hat für mich funktioniert.