Articles of android

Verwenden von cURL in Android

Ich möchte cURL-Bibliothek in meiner Android-Anwendung in nativem Code verwenden (mit NDK r5b, die neueste). Nach der Online-Recherche scheint es, dass cURL nur in android verwendet werden kann, um den gesamten android-Quellbaum mit curl zu erstellen, und irgendwie erzeugt dies eine notwendige Konfigurationsdatei für cURL, um mit Android zu arbeiten. Ich habe keine Erfahrung beim […]

Erstellen und teilen Sie eine Datei aus dem internen Speicher

Mein Ziel ist es, eine XML-Datei im internen Speicher zu erstellen und sie dann über die Freigabe Intent zu senden. Ich bin in der Lage, eine XML-Datei mit diesem Code zu erstellen FileOutputStream outputStream = context.openFileOutput(fileName, Context.MODE_WORLD_READABLE); PrintStream printStream = new PrintStream(outputStream); String xml = this.writeXml(); // get XML here printStream.println(xml); printStream.close(); Ich bleibe stecken, […]

Scrollview kann nur ein direktes Kind enthalten

Ich habe mehrere LinearLayout mit einer kombinierten Höhe, die die Bildschirmhöhe eines Geräts leicht übersteigt. Um mein Layout scrollbar zu machen, habe ich versucht, eine ScrollView , aber leider bekomme ich den folgenden Fehler: Scrollview kann nur ein direktes Kind aufnehmen Ich habe etwas recherchiert, konnte aber nicht wirklich einen Sinn ergeben, wie ich es […]

libavcodec.so: hat Textumsetzungen

Ich teste Android 6.0 auf einem Nexus 5 und ich benutze Metaio (ich weiß, dass der Dienst am 15. Dezember endet, aber für dieses Datum werden wir auf eine andere AR-Plattform wechseln). Das Problem ist, dass wenn ich die ARAktivität starte, der folgende Fehler auftritt: 09-02 08:45:11.138: E/AndroidRuntime(6141): java.lang.UnsatisfiedLinkError: dlopen failed: /data/app/com.myapp.myapp/lib/arm/libavcodec.so: has text relocations […]

Warum verweigert Android WebView die Benutzereingabe?

Ich entwickle eine Android-Anwendung, die ein WebView verwendet, um die Anmeldeseite für Facebook anzuzeigen. Die Seite lädt schön, und ich kann die Benutzernamen / Passwort-Textfelder auswählen, aber die Eingabe funktioniert nicht. Das heißt, sie haben definitiv Eingabefokus (sie haben die orange Fokus-Highlight-Box und einen blinkenden Cursor), aber das Eintippen von ihnen tut absolut nichts. Ich […]

Android – Bild von URL auf SD-Karte speichern

Ich möchte ein Bild von einer URL auf der SD-Karte speichern (für die zukünftige Verwendung) und dann dieses Bild von der SD-Karte laden, um es als ein überziehbares Overlay für Google Maps zu verwenden. Hier ist der Speicherbereich der function: //SAVE TO FILE String filepath = Environment.getExternalStorageDirectory().getAbsolutePath(); String extraPath = “/Map-“+RowNumber+”-“+ColNumber+”.png”; filepath += extraPath; FileOutputStream […]

SharedPreferences und Thread Safety

In den SharedPreferences-Dokumenten heißt es: “Hinweis: Derzeit unterstützt diese class nicht die Verwendung über mehrere processe hinweg. Dies wird später hinzugefügt.” An und für sich scheint es nicht Thread Safe zu sein. Welche Art von Garantien gibt es in Bezug auf commit () und apply ()? Beispielsweise: synchronized(uniqueIdLock){ uniqueId = sharedPreferences.getInt(“UNIQUE_INCREMENTING_ID”, 0); uniqueId++; sharedPreferences.edit().putInt(“UNIQUE_INCREMENTING_ID”, uniqueId).commit(); […]

Android INSTALL_FAILED_UID_CHANGED

Ich habe Debuggen auf Android mit meinem Nexus 4, aber ich habe diesen Fehler vor kurzem hier aufgetreten. Nach einigen Nachforschungen zu diesem Fehler scheint es ein Problem zu sein, dass die App nicht ordnungsgemäß gelöscht wurde. Die App, die ich debugge, läuft gut auf meinen anderen Android-Geräten sowie den Emulatoren, dieser Fehler tritt nur […]

Android Studio build.gradle Warnmeldung

Nachdem ich erfolgreich auf Android Studio 3.1 Canary 9 aktualisiert habe, erhalte ich eine Warnmeldung als Warning:Configuration ‘compile’ is obsolete and has been replaced with ‘implementation’. It will be removed at the end of 2018 Ich weiß, dass diese Warnung zumindest jetzt kein Problem in meinem Projekt verursacht. Aber ich möchte es komplett entfernen, damit […]

Inkompatible Plugins für android-apt nach dem Upgrade auf Android Studio 2.3

Nach dem Upgrade von 2.2 auf 2.3 sehe ich diese Warnung und wenn ich versuche, das Projekt zu kompilieren, sehe ich diesen Kompilierungserrors Wie kann ich dieses Problem lösen, ohne auf eine ältere Version herunterzustufen? Gibt es ein Update von android-apt, das dieses Problem lösen kann?