Articles of Google Play Dienste

Google Play Services-Aktualisierung

Gestern API 19 kam heraus, so aktualisierte ich SDK und andere (einschließlich Google Play Services) jetzt diese Methode: private boolean isGooglePlayInstalled(){ int status = GooglePlayServicesUtil.isGooglePlayServicesAvailable(this); if(status == ConnectionResult.SUCCESS){ return true; }else{ ((Dialog)GooglePlayServicesUtil.getErrorDialog(status, this,10)).show(); } return false; } Wirft an der Linie int status = GooglePlayServicesUtil.isGooglePlayServicesAvailable (this); Caused by: java.lang.IllegalStateException: The meta-data tag in your app’s […]

FusedLocationApi.getLastLocation ist immer null

Ich möchte einfach den Gerätestandort in meinem Android-Projekt abrufen und dazu verwende ich den Play-Services-Ansatz: protected synchronized void buildGoogleApiClient() { mGoogleApiClient = new GoogleApiClient.Builder( MainSearchActivity.this ) .addConnectionCallbacks(new GoogleApiClient.ConnectionCallbacks() { @Override public void onConnected( Bundle bundle ){ Location location = LocationServices.FusedLocationApi.getLastLocation(mGoogleApiClient); if( location == null ){ LocationServices.FusedLocationApi.requestLocationUpdates(mGoogleApiClient, mLocationRequest, new LocationListener() { @Override public void onLocationChanged(Location location) […]

Wie überprüfe ich die Google Play-Dienstversion?

In meiner Anwendung muss ich die Google Play-Dienstversion überprüfen (die auf dem Gerät des Nutzers installiert ist). Ist es möglich ? Und wenn ja, wie kann ich das tun? Ich suchte Google, aber ich konnte nichts finden!

Wie kann ich eine Android-Anwendung in Android Studio erstellen, die Google Maps Api v2 verwendet?

Ich habe in Android Studio eine Menge Probleme damit gehabt, eine App mit GoogleMap zu erstellen. Ich habe die folgende Anleitung vorher mit (fast) keinen Problemen mit Eclipse als meine IDE befolgt: https://developers.google.com/maps/documentation/android/start Ich habe noch nie Android Studio benutzt und ich habe Schwierigkeiten mit dem ganzen Projekt / Modul-Paradigma. Ich konnte das Google Play […]

Konnte com.google.android.gms nicht finden: play-services: 3.1.59 3.2.25 4.0.30 4.1.32 4.2.40 4.2.42 4.3.23 4.4.52 5.0.77 5.0.89 5.2.08 6.1. 11 6.1.71 6.5.87

die Spieldienste über Gradle zu referenzieren, hat aufgehört, für mich zu arbeiten – es hat geklappt – sogar die Probe, die ich als Referenz verwendet habe, hörte überhaupt auf zu funktionieren: https://plus.google.com/+AndroidDevelopers/posts/4Yhpn6p9icf FAILURE: Build failed with an exception. * What went wrong: A problem occurred configuring project ‘:auth’. > Failed to notify project evaluation listener. […]

ClassNotFoundException: Die class “com.google.android.gms.ads.AdView” wurde nicht gefunden.

Ich habe viel recherchiert und dies scheint ein häufiger Fehler für viele Benutzer zu sein, aber aus sehr unterschiedlichen Gründen. Keiner von denen, die ich fand, arbeitete für mich. Ich erhalte java.lang.RuntimeException: Unable to start activity ComponentInfo{ […]/[…].activities.StartActivity}: android.view.InflateException: Binary XML file line #173: Error inflating class […].BannerAd […] Caused by: android.view.InflateException: Binary XML file […]

Android Studio: “Ausführung fehlgeschlagen für Aufgabe ‘: app: mergeDebugResources'” wenn Projekt auf Laufwerk C: erstellt wird:

Ich habe die Google Play-Dienste als Abhängigkeit in meinem aktuellen Projekt hinzugefügt. Wenn ich das Projekt auf Laufwerk C: speichere, erhalte ich den folgenden Fehler beim Synchronisieren des Projekts: Error: Execution failed for task ‘:app:mergeDebugResources’. > Error: Failed to run command: C:\Program Files (x86)\Android\android-studio\sdk\build-tools\android-4.4.2\aapt.exe s -i C:\Users\ashokp\Desktop\Studio\AndroidV2SDK_AndroidStudioFormat\Google Play Services\SampleApplication\AndroidV2SDKSampleApp_GooglePlayServices\app\build\exploded-aar\com.google.android.gms\play-services\4.3.23\res\drawable-hdpi\common_signin_btn_text_focus_light.9.png -o C:\Users\ashokp\Desktop\Studio\AndroidV2SDK_AndroidStudioFormat\Google Play Services\SampleApplication\AndroidV2SDKSampleApp_GooglePlayServices\app\build\res\all\debug\drawable-hdpi\common_signin_btn_text_focus_light.9.png Error Code: […]

Fehler erhalten: Die class ‘android.app.AppOpsManager’ konnte nicht gefunden werden, auf die von der Methode com.google.android.gms.common.GooglePlayServicesUtil.zza verwiesen wird

Ich erhalte diesen Fehler, und das Programm stürzt ab, wenn ich versuche, die App mit älterem Telefon als auf API-Ebene 22 zu starten. Die App funktioniert jedoch gut mit dem Telefon mit API-Stufe 22. Was könnte der Grund dafür sein? Hier sind meine Abhängigkeiten: dependencies { compile ‘com.google.code.gson:gson:2.3’ compile ‘com.android.support:appcompat-v7:22.2.0’ compile ‘com.android.support:recyclerview-v7:+’ compile ‘com.android.support:support-v4:22.2.0’ compile […]

GCM SERVICE_NOT_AVAILABLE auf Android 2.2

Ich erhalte den Fehler “SERVICE_NOT_AVAILABLE” in meinem GoogleCloudMessaging.register () -Aufruf auf einem Android 2.2-Gerät. Ich schreibe eine App, die GoogleCloudMessaging mit den neuen Google Play-Diensten verwendet. Ich implementierte es mithilfe der Richtlinien, die auf der Android-Website bereitgestellt werden, und meine Quelle enthält viele Fehlerprüfungs- und Bearbeitungscodes, z. B. um sicherzustellen, dass die Google Play-Dienste installiert […]

Android Play Services 6.5: LocationClient fehlt

Nach dem Update auf Google Play Services 6.5.87 konnte meine App aufgrund fehlender LocationClient-class nicht kompiliert werden. Der Dokumentationslink ist im Moment beschädigt (404 Not Found) Wie kann ich es reparieren? Ich möchte Standort-Updates erhalten, mit Geofences arbeiten, etc ..